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MAP II  
A Geographic Information System for the Macintosh

Map Processor
®

AN INTRODUCTION

This introduction is intended to accompany a disk containing a demo version of the MAP II map 
processor and sample data files for both color and black-and-white systems.  The program will run on 
the Macintosh Plus®, the Macintosh SE®, the Macintosh II® andthe Macintosh IIx®.  MAP II requires 
the Macintosh System Version 6.0 or higher.  There is no installation procedure.  Simply insert the demo 
disk in the drive of your Macintosh and double click on the MAP II demo icon.  The attached 
introduction will get you started. 

MAP II:  MAP II is a new spatial analysis tool:  a map processor.  A map processor manipulates 
information on both the visual level and the quantitative level.  It departs from traditional GIS in its user 
friendliness, emphasis on map visualization, ease of input and output, and the ability to perform spatial 
analysis using screen tools and menu choices, as well as text-based map operations.

The demo version:  The demo version of MAP II makes available to you all the functions of MAP II, 
with three important exceptions:

1. The data files that come with the demo program cannot be permanently changed or deleted.
Changes to these maps will appear on the screen, but are temporary and cannot be saved.

2. Although temporary maps can be imported or created within MAP II, these maps cannot be
saved.

The introduction: This introduction guides you through the major features of MAP II using the 
sample data.  It certainly isn't exhaustive, but it should give you a good feel for the things that MAP II 
can do.  The sample data is there to experiment with, so feel free to try things with it.  The introduction 
assumes that you are familar with the Macintosh, so no attempt has been made to explain things like 
double clicking and using pull-down menus.  If you are a relatively new user of the Macintosh, you may 
find it useful to refer to your Macintosh manual.
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AN INTERACTIVE INTRODUCTION TO THE MAP II MAP PROCESSOR

 
Nancy Thies, K Chris Kirby, Micha Pazner

STARTING MAP II

1. Insert the demo disk in the drive of your Macintosh Plus, Macintosh SE, Macintosh II
or Macintosh IIx.

2. Open the the MAP II Demo disk.
3. Double click on the MAP II Demo icon .

I. VIEWING MAPS AND LEGENDS 

1. Getting started:
Open the MAP II Demo Data folder, then open the Terrain Project.  A project lists maps that can be
used together for analysis.  Projects can list from one to 32,000 maps.

2. Viewing a map:
The project directory is an alphabetical list of the maps grouped together in the project.  To open a 
map double click on the map name in the project directory.  If you are using a Macintosh Plus or 
Macintosh SE, open B&W Sample Terrain.  If you are using a Macintosh II or Macintosh IIx, open
Color Sample Terrain.

The map window should look something like this:

Map Scale 
Control

Screen Tools 

Color/Pattern & Value Fields
Scroll Bars

Size Box

Window Zoom BoxClose Box

An Interactive Introduction to MAP II    2



3     An Interactive Introduction to MAP II
The map window has many standard Macintosh window features:
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To move the window  click on the title bar and drag.

Use the size box in the lower right-hand corner to make the window larger or smaller.  To get a 
full-screen display, click the zoom box upper right-hand corner.  Click the zoom box again to 
return to the original window size.

To scroll the map within the window, use the scroll bars on the right side and bottom of the 
window.

The map window also has some features unique to MAP II.  These include the map scale control, 
the screen tools, and the color/pattern and value fields (the value field is shown empty in the figure
preceding this description.)

To change the scale of the map, use the map scale control.  There are seven possible settings.  1 is 
the smallest scale and 7 is the largest scale.  Click and drag the bar down to display a larger scale.  
Move the bar all the way up to select the smallest scale.  While the map is redrawing, hold 
Command (.) down to stop the redraw, then hold the shift key and click on the map scale control 
bar to refresh the map display.

3. Map format: 
To display map rulers:

Choose Format Map in the Edit menu, then choose Rulers from submenu.  The default ruler units 
are map units, in this case meters.  The units used are shown in the corner where the rulers meet.  
Here, the abbreviation "m" stands for meters.

Go back to the Edit menu, choose Format Map and Cell Units; the rulers now display row and 
column coordinates indicated by RC (row-column.)

Go back to the Edit menu, choose Format Map and Tracker.  Move the pointer over the map.  The 
pointer position is indicated by wedges on the rulers and the exact coordinates are given by the 
position trackers at the bottom of the window.  The  symbol gives the vertical coordinate and the

 symbol gives the horizontal coordinate.  The  symbol represents the distance tracker and gives 
the distance from the last selected cell or the upper right corner of the last selected area.  (Selection
is covered in the next section.)  If the distance tracker is not visible, enlarge the map window.  To 
see how the distance tracker works, move the pointer over the map, click anywhere, move the 
pointer and watch the tracker.  Tracker units match ruler units.
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Rulers showing map units Rulers and trackers showing cell units
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4. Viewing the legend:  
The legend is automatically displayed when the map is opened.  If the legend window is not 
immediately visible, it is probably stacked beneath another window.  To make the legend window 
active and visible, go to the Windows menu and choose Map's Legend.  The legend should look 
something like this:

Close Box Window Zoom Box

Size Box

Scroll Bar

To move the legend, click on the title bar and drag the window.  To change the window size, click 
in the window zoom box in the upper right-hand corner for a full-screen display, click again to 
return to the original window size, or use the  size box in the lower right-hand corner.

Scroll the legend within the window using the scroll bar on the right side of the window.

To close and reopen the legend: click the close box in the upper left corner of the legend window, 
then go to the Windows menu and choose Map's Legend.

5. Legend format
The legend format can be changed.  To do so, the legend window must be active.  To make the 
legend window active, click anywhere in the window.  

Go to the Edit window, choose Format Legend.  To display the number of cells in each map zone, 
choose Zone Count from the submenu; to display text describing each zone or category, choose 
Zone Text from the submenu.

Color/Pattern 
Rectangles

Zone Values

Zone Count

Zone Text
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6. Legend text editing:

Legend text can be entered and edited.  To do so, the legend window must be active.  

Click to right of the cell count next to "VOID".  Type:  Thompson River.  To remove what you've 
typed, select the text by clicking and dragging and press delete/backspace on the keyboard.

7. Map viewing is closely related to using the legend:
Make the map window active.  Move the pointer over the map and it becomes a cross hair.  Click 
anywhere on the map and the color/pattern and value fields will show the cell parameters for the 
clicked cell.  Look at the legend.  The same legend category/map zone will be selected there.

8. To quit:
Choose Quit from the File menu.  All windows will close automatically.

9. To continue:
Go directly to Section II, CHANGING THE COLORS/PATTERNS USED IN MAPS.

II. CHANGING THE COLORS/PATTERNS USED IN MAPS 

1. If MAP II is not up and running, open MAP II, the appropriate data folder, then the 
Terrain Project, and then the map Sample Terrain.
Make sure that the map window is active.  If the map rulers and/or trackers are displayed, go to the
Edit menu, choose Format Map… and then select Rulers and/or Tracker in the submenu to turn 
these features off.

Map scale setting 2 (1 is the top of the scale, 7 is the bottom of the scale) works well for viewing 
color/pattern changes.  If the map scale is not already at that setting, change the scale setting, then 
resize the map window so that it takes up about one third of the screen.  The map window should 
look something like this:  

2. To change the color/pattern of one zone, use the legend:
The legend window must be active.  Click on the color/pattern rectangle in the legend that 
represents the map zone with the value VOID.

Macintosh Plus and Macintosh SE users will get this dialog box:
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Patterns can be viewed by scrolling the bar using the scroll arrows.  Choose a pattern by clicking 
on the bar—the choice will appear in the left-hand display box.  Click OK.  The new pattern will 
appear in the map and the legend.

Macintosh II users will get this dialog box:

There are three bars in this dialog box:  the Pattern bar, labelled "P", the Foreground color bar, 
labelled "F", and the Background color bar, labelled "B".  These bars can be scrolled using the 
scroll arrows to view the available patterns and colors.

To choose a solid color, click the solid black square on the bar labelled "P", then click the color 
desired on the bar labelled "F".  The choice will appear in the left-hand display box.  Click OK.  
The new color will appear in the map and the legend.

To choose a color pattern, click the desired pattern on the bar labelled "P".  Click the foreground 
color (corresponding to black in the pattern display) on the bar labelled "F".  Click the background 
color (corresponding to white in the pattern display) on the bar labelled "B".  The choice will 
appear in the left-hand display box.  Click OK.  The new color will appear in the map and the 
legend.

3. To assign one color/pattern to a range of map zones:
The map window must be active.  Then, choose Color Map from the Edit menu and Constant… 
from the submenu.

Macintosh Plus and Macintosh SE users will get this dialog box:

Macintosh II users will get this dialog box:
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Click From and type 950 as the From value and 1150 as the To value.
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Click the button beside the word Pattern (if you are using a Macintosh Plus or Macintosh SE) or 
the word Color (if you are using a Macintosh II.)  An empty rectangle will appear.  Click the 
rectangle.  The same dialog box used to select the color/pattern for a single zone will appear.

Use the dialog box to select a pattern or color.  Click OK.

This will return the Constant Color dialog box with the selected color/pattern displayed.  Click 
OK.  The new color/pattern will appear in the map and the legend for zones with value 950, 1050, 
and 1150.

4. To create a gray pattern sequence:
The map window must be active.  Choose Color Map from the Edit menu and Pattern Sequence… 
from the submenu.  The following dialog box will appear:

The default sequence is a gray pattern (patterns made up of black and white dots) sequence ranging
from dark to light.  Choose Reverse.  The display bar will show the reverse sequence, from light to 
dark.  Click OK.  The new sequence will appear in the map and the legend.

FOR THE MACINTOSH II AND MACINTOSH IIx ONLY 
5. To create a true gray monochrome sequence:

The map window must be active.  Choose Color Map from the Edit menu and Color Sequence… 
from the submenu.  The following dialog box will appear:

The default sequence is a gray monochrome sequence, applied to all map zones.  Colors (including
grays) can correspond to colors on the monitor's color card or can be dithered.  Dithered colors are 
approximated by an array of different colored dots on the screen.  

Click No Dithering and note the change in the indicator bar.  There is a tradeoff:  with dithering, 
many more colors become available, however, nondithered colors generally result in a better 
display and a better printed map.

Click OK to implement the sequence.  It will apply to all nonvoid map zones, both in the map and 
the legend.
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FOR COLOR SYSTEMS ONLY
6. To create a green monochrome sequence:

The map window must be active.  Choose Color Map from the Edit menu and Color Sequence… 
from the submenu.  When the Color Sequence dialog box appears, click on the indicator bar.  A 
new dialog box, the color wheel dialog box comes up.  The color wheel dialog box allows you to 
choose dithered colors.

Choose a green by moving the pointer over the wheel and clicking on the desired color.  The 
chosen color displays in the box in the upper left-hand corner of the dialog box.  Click OK to 
return to the Color Sequence dialog box.  A monochrome sequence based on the selected hue will 
be displayed in the indicator bar.

Click No Dithering and note the change in the indicator bar.  Click OK to implement the sequence.
It will apply to all nonvoid map zones, both in the map and the legend.

FOR COLOR SYSTEMS ONLY
7. To create a linear RGB sequence:

The map window must be active.  Choose Color Map from the Edit menu and Color Sequence… 
from the submenu.  Click Linear RGB and note the change in the indicator bar.

Click the small box at the left end of the bar.  The color wheel dialog box will come up.  The linear
RGB sequence is constructed by following a straight line across the color wheel from the color 
corresponding to one end point of the indicator bar to the color corresponding to the other end 
point of the indicator bar.

Choose a new end point by positioning the pointer over the wheel and clicking.  Click OK to return
to the Color Sequence dialog box.  Click OK to implement the sequence.  It will apply to all 
nonvoid map zones, both in the map and the legend.

FOR COLOR SYSTEMS ONLY
8. To create a multichrome sequence:

The map window must be active.  Choose Color Map from the Edit menu and Color Sequence… 
from the submenu.  Click Multichrome and note the change in the indicator bar

Click the small box at the left end of the bar and the color wheel dialog box will come up.  The 
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multichrome sequence is constructed by following an arc around the color wheel in a clockwise 
direction from the color corresponding to the left end point to the color corresponding to the right 
end point.
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Click Cancel to return to the Color Sequence dialog.  Click OK to implement the sequence.  It will 
apply to all nonvoid map zones, both in the map and the legend.

9. To quit:
Choose Quit from the File menu.  All windows will close automatically.

10.To continue:
Go directly to Section III, CUT-AND-PASTE AND SCREEN TOOL EDITING.

III. CUT-AND-PASTE AND SCREEN TOOL EDITING

1. To use the selection tool:
The map window must be active and the selection tool must be turned on.  When the selection tool 
is turned on, the icon on the left side of the map window is dark.  If the tool is not on, click on the 
icon.

Selection Tool Icon
Point Tool Icon
Line Tool Icon

Polygon Tool Icon

Color/Pattern Field

Value Field

The selection tool can select a rectangular area ranging in size from one cell to the entire map.  To 
select an area, move the pointer over the map.  The pointer will become a dashed crosshair.  Click, 
drag, and release—the selected area will appear on the map outlined with a flashing dotted line.

To cancel the selection, click on the selection tool icon.

If necessary, rescale and resize the map so that all of the river is visible.  Select a rectangle 
containing all of the river, similar to what is shown in the following figure.  (The dotted line 
surrounding the selected area is exaggerated in the figure for better visibility.)
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2. To copy a selected area to the clipboard:
Go to the Edit menu and choose Copy.

3. To create a new map consisting of the copied area:
Close the original map (Color Sample Terrain or B&W Sample Terrain) by clicking in the close 
box in the upper left corner of the map window.  Go to the Edit menu and choose Paste to New 
Map.  A new, temporary map named ThatMap-1 will be created from a copy of the selected area.  
Temporary maps do not exist on disk, but can be viewed, edited, and used in map operations.  

4. The screen tools:
The point, line, and polygon tools are used to add or change information in maps.  The point tool is
used to draw single cells or small, irregular areas.  The line tool is used to draw straight lines.  The 
polygon tool is used to draw either open polygons, which appear as broken lines, or closed, filled 
polygons.

Make sure that the temporary map, ThatMap-1, is active.  Rescale the map to scale setting 3 (1 is 
the top, 7 is the bottom) and resize the window so that the north half of the river is visible.  

To turn on the point tool, click on the point tool icon on the left side of the map window.  Refer to 
the figure at the beginning of the section to find this icon..

The point tool will be used to add campsites, represented by single cells with value 5, to the 
temporary map ThatMap-1.

5. Assigning color and value to the point tool:
To assign a color/pattern to the point tool, click the color/pattern field at the bottom of the map 
window.  The Color/Pattern dialog box will come up.  Choose a color or pattern that contrasts with 
the map zone in which the points will be added and click OK.  

To assign a value to the point tool, click the value field at the bottom of the map window.  Type the
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number 5 using the number keys at the top of the keyboard or the numeric key pad.
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6. Making changes using the point tool:

Using the following contour map as a guide, position the pointer at the location of the most 
northerly campsite.  Notice that when the point tool is turned on and the pointer is moved over the 
map it becomes a pencil.

N

Campsites

When the point tool is properly positioned, click.  The cell directly beneath the point tool now has 
the new color/pattern and the value 5.  Notice that the legend now shows this new map zone.

Enter the remaining three campsites the same way.  If you wish to correct a cell go immediately to 
the Edit menu and choose Undo Point(s).  The Undo function will undo any points entered 
between the last time the mouse was clicked and then released.

7. To discard the temporary map:
Click the map window close box.  You will get the following warning

To discard the map, click the Discard button.  To keep the map until you quit MAP II, click the 
Cancel button.  Maps cannot be saved in this demo version of MAP II.

8. To quit:
Choose Quit from the File menu.  All windows will close automatically.

9. To continue:
Choose Close Project from the Project menu.  All windows will close automatically and the open 
project dialog box will appear.  Open the Terrain Project, then go to Section V, PRINTING MAPS.
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V. PRINTING MAPS

1. If MAP II is not up and running, open the MAP II Demo, the MAP II Demo Data folder 
and then the Terrain Project.  If you will be printing on a color printer open Color 
Sample Terrain.  Otherwise, open B&W Sample Terrain.
To print a map, it must be open and the map window must be active.  

Go to the File menu and choose Page Setup…  Choices in this dialog box depend on the type of 
printer being used.  However, this is always the place that paper size is specified.  Make sure that 
standard US Letter paper is selected.  (If this size paper is not available, select a paper size that is 
available and that is close to US Letter.)  Click OK.

2. Using the Page Layout dialog:
Choose Page Layout… from the File menu.

Title bar

Layout box

Map rectangle

Legend rectangle

Legend 
design

Map design

Scroll 
bars

Edge of 
page

Click and drag the legend rectangle to the bottom of the page.  Click and drag the map rectangle so
that it is centered above the legend rectangle.

Go to the field labelled "Title" and select the field by clicking and dragging.  Type a new map title:
Elevation in meters - Thompson River Valley

This title will appear on the printed map but the name of the map on disk will not change.

Click the Print button.  When the Print dialog box appears, make sure that it is set to print one copy
of all pages, then click the OK button.

A print job can be cancelled by either clicking the Cancel button that appears after the print has 
begun, or by holding the Command key and pressing the (.) (period) key.

The appearance of the printed map will depend on the type of printer being used.  A color printer 
will produce a printed map with colors and patterns that match those of the map on the screen.  A 
laser printer will print white, black and most black and white patterns as they appear on the screen 
but gray patterns and all colors will be translated to gray halftones.  Other printers—for instance, 
the ImageWriter®—will print all black and white patterns as they appear on the screen and 
translate colors into gray patterns.
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3. Changing legend design:

Look at the legend design area of the dialog box.  Click the button labelled "Horizontal Bar."  This 
will cause the legend to print as a continuous bar scale rather than as a list.

Use the legend scroll bar to resize the legend.  Moving the scroll box to the left will make the 
legend shorter; moving the scroll box to the right will make the legend longer.

After choosing a legend size, click and drag the legend rectangle to position it on the page.

Click the Print button.  When the Print dialog box appears, make sure that it is set to print one copy
of all pages, then click the OK button.

When the print is complete, click the Cancel button to cancel the Page Layout dialog box.

4. To quit:
Choose Quit from the File menu.  All windows will close automatically.

5. To continue:
Choose Close Project from the Project menu.  All windows will close automatically and the open 
project dialog box will appear.  Open the S. E. MANITOBA PROJECT, then go to Section VI, 
TRANSFORMING MAPS.

VI. TRANSFORMING MAPS 

1. If MAP II is not up and running, open the MAP II Demo, the MAP II Demo Data folder,
then the S. E. MANITOBA PROJECT.  
Use the project directory to open the map HYDRO-PARK-FOREST.  Resize and rescale the map 
so that the map scale setting is at the top and the map window is sized to just frame the map.  
Reformat the legend using the Format Legend…choice in the Edit menu so that Zone Text is 
displayed.  Resize the legend to display all the categories and associated text.

This map shows the hydrology—lakes, rivers and the man-made floodway protecting the city of 
Winnipeg—and the provincial parks and forests in the southeastern portion of the province of 
Manitoba in Canada.  A map operation will be used to create a new map showing only the rivers in 
this region.  Note that on this map, the rivers are represented by the map zone having the value 12.

2. What are map operations?
Map operations create new maps by manipulating the values of one or more existing maps.  The 
existing maps are not changed in any way.  The map operations used in MAP II are based on the 
Map Algebra developed by C. Dana Tomlin.  Map operations can be used—among other things—
to measure distance, enhance and classify remote sensing images, perform map overlay operations,
compute time-series averages, and do terrain analysis and geometric rectification. 

3. Using the operation window:
Go to the Windows menu and choose Operation.
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A map operation is performed by stating the operation in the Operation Specification field, then 
clicking the Execute button.  The Operation and Map lists below the Operation Specification field 
are used to construct the operation statement using cut and paste techniques.

The maps list contains, in alphabetical order, the names of maps in the currently open project.  
Only the maps in the current project can be used in operations.

4. Using the RECODE operation to extract information:
The Recode operation allows you to assign new values to map zones.  A new map will be created 
by assigning 10 to the map zone representing rivers (which in the old map has value 12) and VOID
to everything else.  The operation statement to do this will read:

Recode HYDRO-PARK-FOREST Assigning 10 To 12

The only values that have to be explicitly stated are the values representing the rivers in the two 
maps.  Any map zones not specifically assigned values in the operation statement will be given the 
value VOID in the new map.

To create this statement in the operation window, first scroll the operations list until Recode<map>
is visible, then double click it to paste it in the operation specification area.  The operation list will 
become a list of modifiers that can be used with this particular operation.  Double click on 
Assigning <value>, then double click on To <value>.  The operation specification window should 
now read:

Recode <map> Assigning <value> To <value>

In the operation specification area, double click on the placeholder <map>.  Then go to the map list
and double click on the map name HYDRO-PARK-FOREST.  The map name will replace the 
place holder.  In the operation specification area, double click on the first placeholder <value>.  
Using the number buttons at the bottom of the window, click first "1" then "0" so that the number 
10 replaces the place holder.  Then in the operation specification area, double click on the second 
placeholder <value>.  Using the number buttons at the bottom of the window, click first "1" then 
"2" so that the number 12 replaces the place holder.  The operation statement should now be 
complete.  If you make an error while constructing it, click the Clear button and start over.

To execute the operation, click the Execute button.  As the operation is executed, the status bar will
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fill to indicate the proportion of the operation that has been completed.  To stop the operation 
before completion, click the Cancel button.
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When the operation has been completed, the operation window will clear and a new temporary 
map, the result of the operation, will display.  This map will show only the rivers in the study area. 
You may wish to resize and rescale the map to better see the information.

Click on the legend window to make it active.  Go to the Edit menu and choose Format Legend…, 
then Zone Text.  In the legend window, click to the right of the value 10.  Type the word:  Rivers.

5. Using the COVER operation to combine information
The Cover operation allows you to "superimpose" two maps.  The resulting new map will have all 
the information of the "upper" map and any of the information of the "lower" map that corresponds
to areas in the "upper" map having the value VOID, like a transparent overlay.

The map created by using the Recode operation (ThatMap-1) will be covered by a map of 
settlements.  The resulting map will show both rivers and settlements.

Go to the Windows menu and choose Operation.  The operation statement that will be constructed 
will read:

Cover ThatMap-1 With SETTLEMENTS

Scroll the operation list, find the operation Cover <map> and double click on it to paste it in the 
operation specification area.  Find the modifier With <map> in the modifier list and double click it.
The operation specification area should now read:

Cover <map> With <map>

In the operation specification area, double click on the first placeholder <map>.  Then go to the 
map list and double click on the map name ThatMap-1.  The map name will replace the place 
holder.  In the operation specification area, double click on the second placeholder <map>.  Then 
go to the map list and double click on the map name SETTLEMENTS.  The map name will 
replace the place holder and the operation statement will be complete.

Click the Execute button.

The resulting map, ThatMap-2, will show both rivers and settlements.  You may wish to resize and 
rescale the new map in order to see it better.  Make the legend window active, then go to the Edit 
menu, choose Format Legend and Zone Text.  Note that the color/pattern and legend text of the 
maps used in the operation carry over to the new map.

6. Using the SPREAD operation to generate buffers
The Spread operation can be used to generate buffer zones; the new map has map zones that 
represent distances from nonzero, nonvoid cells in the original map.

The Spread operation can be used with the new map of rivers to identify a 5 km flood-prone area 
on either side of the rivers.  The operation statement to do this is:

Spread ThatMap-1 To 5
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Go to the Windows menu and choose Operation.  Scroll the operation list, find the operation 
Spread <map> and double click on it to paste it in the operation specification area.  Find the 
modifier To <value> in the modifier list and double click it.  The operation specification area 
should now read:
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Spread <map> To <value>

In the operation specification area, double click on the first placeholder <map>.  Then go to the 
map list and double click on the map name ThatMap-1.  The map name will replace the place 
holder.  In the operation specification area, double click on the placeholder <value>.  Go to the 
number buttons at the bottom of the window and click on 5.  The value 5 will replace the place 
holder and the operation statement will be complete.

Click the Execute button.

The resulting map will show a 5 km buffer on either side of the rivers; the value of each map zone 
within the buffer is the distance in meters from the river.

Choose Close Project from the Project menu.  All windows will close automatically.  As the 
temporary maps close, you will get a warning message.  Click the Discard button for each map.  
The Open Project dialog box will appear.  Open the St Norbert Project.  

Image processing
7. Using the FILTER operation for edge detection:

The Filter operation allows you to use a variety of filtering techniques.  In particular, the Sobel 
filter can be used to produce an image in which edges or gradients are enhanced.  

Use the project directory to open the map St Norbert tm3.  This map represents Landsat Thematic 
Mapper band 3.  The image is of St. Norbert, a community in the south end of the city of 
Winnipeg, and was acquired on September 8, 1985.  This image is best viewed at scale setting 2, 
so rescale and resize the map to get a good look at it.

If you are using a Macintosh II, you can enhance this image to some extent using color 
management.  Choose Color Map from the Edit menu, then choose Color Sequence from the 
submenu.  Choose a monochrome sequence with the No Dithering option.  Compare the result with
the original image.

To apply the Sobel filter to this image this operation statement will be used:

Filter «St Norbert tm3» Sobel 

Go to the Windows menu and choose Operation.  Scroll the operation list, find the operation Filter 
<map> and double click on it to paste it in the operation specification area.  Find the modifier 
Sobel in the modifier list and double click it.  The operation specification area should now read:

Filter <map> Sobel

In the operation specification area, double click on the placeholder <map>.  Then go to the map list
and double click on the map name St Norbert tm3.  The map name will replace the place holder.  
The operation statement should now be complete.
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Click the Execute button.

You can further enhance this image using color management.  Go to the Edit menu and select 
Color Map and Constant…  First click the button for White, then click the From button and type 0 
as the From value and 32 as the To value.  Click OK.  Map zones 0 through 32 will now be white.
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Go back to the Edit menu and again select Color Map and Constant.  This time click the Black 
button , then the From button and type 65 as the From value and leave the To value at the default.  
Click OK.  Map zones with value 65 and greater will now be black.

Finally, go to the Edit menu and Select Color Map and Pattern (for the Macintosh Plus and 
Macintosh SE) or Color Sequence (for the Macintosh II.)  A gray sequence will be assigned to map
zones 33 through 64.  In either dialog box, click the From button and type 33 for the From value 
and 64 as the To value.  Then click Reverse.  Click the OK button to apply the sequence.

Compare the resulting map with the original image St Norbert tm3.

8. To quit:
Choose Quit from the File menu.  All windows will close automatically; when the warning 
message comes up for the temporary map, click the Discard button.

FOR COLOR SYSTEMS ONLY
9. Using the MERGE operation to create a multispectral composite:

Use the project directory to open the maps St Norbert tm4 and St Norbert tm5.  These maps 
represent Landsat Thematic Mapper bands 4 and 5.  The images are of the same area of St. Norbert
as St Norbert tm3, and were also acquired on September 8, 1985.  

Resize and rescale these maps to get a good look at the images.

The Merge operation merges the information in the three images to produce a multispectral 
composite.  The operation statement will read:

Merge Red «St Norbert tm3» Brightness 400 Blue «St Norbert tm4»  Brightness 200 
Green «St Norbert tm5» Brightness 200 NoDither

The modifier Brightness assigns a brightness factor, in percent, to each map.  The modifier 
NoDither produces a map without dithered colors.  In general, a nondithered image both displays 
and prints better than one that includes dithered colors.

Go to the Windows menu and choose Operation.  Scroll the operation list, find the operation Merge
and double click on it to paste it in the operation specification area.  Find the modifier Red <map> 
in the modifier list and double click it.  Continue the process by pasting in the remaining modifiers 
in the following order:  Brightness <value>, Blue <map>, Brightness <value>, Green <map>, 
Brightness <value>, NoDither.  The operation specification area should now read:

Merge Red<map> Brightness <value> Blue<map> Brightness <value> Green<map> 
Brightness <value> NoDither

In the operation specification area, double click on the first placeholder <map>.  Then go to the 
map list and double click on the map name St Norbert tm3.  The map name will replace the place 
holder.  In the operation specification area, double click on the placeholder <value>.  Go to the 
number buttons at the bottom of the window and click first on 4 then 0 and 0 again.  The value 400
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will replace the place holder.  Continue the process, pasting in the remaining map names and the 
appropriate brightness values until the operation statement is complete.

Click the Execute button.
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The resulting map will show a multispectral composite of the St. Norbert area.  

11.To quit:
Choose Quit from the File menu.  All windows will close automatically.
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